Xposed est désormais téléchargeable en version officielle sur le forum XDA. Son développeur vient d’y fournir une version du framework compatible avec les appareils sous Android 5.0 et 5.1.

Xposed-Framework-790x395

Après une phase d’alpha-test qui aura duré de longs mois, Xposed est désormais disponible en version finale pour Android 5.0 Lollipop, ainsi que pour sa mouture 5.1. Le framework était en cours de test par Rovo89, son célèbre développeur, depuis le début de l’année, alors même qu’il avait initialement indiqué son intention de laisser de côté ce projet chronophage, la faute aux importants changements apportés par Lollipop à KitKat. Après six mois de développement, le voici qui publie le fruit de ses travaux sur le forum XDA.

Si le framework, qui autorise une personnalisation avancée des smartphones ou tablettes qui en seraient équipés, est conçu pour fonctionner sur les terminaux Android 5.0 comme 5.1, Rovo89 précise tout de même que certaines difficultés peuvent être rencontrées. Il signale ainsi des cas de bootloops (blocages au démarrage) sur des terminaux Samsung tournant sur des ROM stock, « causés par les modifications apportées à ART par Samsung », et qui conduiront les plus experts à modifier les ROM en question. Ce n’est toutefois pas une grosse surprise, puisque le développeur avait rapporté, dès les premiers tests qu’il avait réalisés, avoir rencontré d’importantes difficultés avec TouchWiz, l’interface du Coréen. Autre point à noter, des cas de messages d’erreur « fatal signal 6 » sur des terminaux Sony dont la ROM souffrirait d’éléments corrompus (services.odex). Rovo indique ne pas être pour le moment en mesure de résoudre ces soucis.

Ces restrictions à l’installation du framework Xposed sur certains terminaux rappellent en tout cas que l’opération n’est jamais sans risque, quel que soit le terminal choisi. L’ensemble des fichiers nécessaires est quoi qu’il en soit disponible à cette adresse (pour ARM64, ARM ou X86), accompagné des indications nécessaires à l’installation.